Skip to content

System Requirements

Warning

Dokku Pro 1.2+ will refuse to start if the minimum Dokku version is not installed.

Plugin Requirements

Warning

Dokku Pro 1.2+ will refuse to start if an installed plugin is not at the minimum supported version.

Datastores

The following official datastore plugins are supported at the specified versions. Users should upgrade their plugins prior to updating or installing Dokku Pro.

Plugin Version
clickhouse 0.17.0
couchdb 1.25.0
elasticsearch 1.24.0
graphite 1.22.0
mariadb 1.24.0
meilisearch 0.6.0
memcached 1.22.0
mongo 1.21.0
mysql 1.23.0
nats 1.24.0
omnisci 1.23.0
postgres 1.24.0
pushpin 0.14.0
rabbitmq 1.24.0
redis 1.24.0
rethinkdb 1.21.0
solr 1.24.0
typesense 1.5.0

Others

New as of 1.2

The following optional plugins may be installed for http-auth and maintenance functionality.

Plugin Version
http-auth 0.10.0
maintenance 0.7.0

  1. RHEL and ARM/ARM64 Support coming soon